Configurer un VLAN

Dans cet article, nous allons apprendre à configurer un VLAN ainsi qu’à configurer les interfaces dans le VLAN.

Un VLAN est un réseau virtuel. Il regroupe de façon indépendante plusieurs machines de votre parc.

Nous partons du principe que vous avez donné un nom au commutateur et n’avez aucune configuration pour le moment.

Sommaire

Créer un VLAN

Pour créer un VLAN, tapez les commandes suivantes :

conf t
vlan 2
name NomVlan
exit

La commande “conf t” permet d’accéder au mode configuration. La deuxième commande créée ou modifie le VLAN dont l’identifiant est 2. La commande “name” suivie du nom du VLAN définie un nom au VLAN. Puis la commande “exit” permet de revenir en mode configuration.

Supprimer un VLAN

Pour supprimer un VLAN, tapez les commandes suivantes :

conf t
no vlan id
exit

La commande “no vlan id” va supprimer le vlan dont l’identifiant est id.

Configurer les interfaces non taguées

Pour identifier les flux de chaque VLAN, nous taguons la trame Ethernet. En faisant cela, on ajoute un identifiant pour identifier quels appareils correspondent au trafic. La différence entre port tagué et non tagué réside dans le fait de retirer le tag ou non après un envoie du trafic. Si le port du commutateur envoie le trafic après avoir retiré le tag du VLAN, alors il est non tagué. Sinon, si le port envoie le trafic sans avoir retiré le tag du VLAN, il est tagué.

Pour affecter une interface non taguée dans un VLAN :

conf t
int f0/1
switchport mode access
switchport access vlan 2
exit

La commande “int f0/1” permet d’accéder à la configuration du port FastEthernet 0/1. La commande du dessous spécifie le mode de l’interface (cela désactive le mode trunk) et la commande de la ligne 3 affecte le port au vlan 2.

Pour information, le mode trunk permet de relier deux équipements entre eux. Il permet de faire passer tous les VLAN. On dit qu’il “appartient” à plusieurs VLAN.

Pour affecter un ensemble d’interfaces non taguées dans un VLAN, vous pouvez remplacer la ligne 2 par “interface range” :

conf t
interface range f0/1 - 10
switchport mode access
switchport access vlan 2
exit

La commande à la ligne 2 va affecter les 10 ports FastEthernet du switch.

Pour supprimer l’affectation d’une interface non taguée à un VLAN :

conf t
int f0/1
no switchport access vlan 2
exit

La commande “no switchport access vlan 2” va supprimer l’affectation au VLAN 2.

Configurer les interfaces taguées

Pour affecter une interface taguée dans tous les VLAN, tapez les commandes suivantes :

conf t
int f0/1
switchport trunk encapsulation dot1q
switchport mode trunk
exit

La commande de la ligne 4 va affecter ce port à tous les VLAN.

Pour afficher les VLAN avec les interfaces affectés :

show vlan

Configurer une adresse IP au VLAN

Affecter une adresse IP à l’interface d’un VLAN :

conf t
int vlan 2
ip address 10.0.0.254 255.0.0.0
no shutdown
exit

La commande “int vlan 2” permet d’accéder à la configuration de l’interface du VLAN 2. La commande du dessous va affecter une adresse IP à l’interface virtuelle. Avec la commande “no shutdown“, nous activons l’interface virtuelle du VLAN 2.

Pour supprimer une adresse IP d’un VLAN, on insère les instructions suivantes :

conf t
int vlan 2
no ip address
exit

La commande “no ip address” permet de supprimer l’adresse IP.

Pour configurer la passerelle par défaut sur un switch, nous tapons les commandes suivantes :

conf t
ip default-gateway 10.0.0.1

Remplacez bien sûre l’adresse IP par votre passerelle.

Puis, pour configurer l’adresse IP d’un serveur DNS sur votre commutateur :

conf t
ip name-server 10.0.0.10

Vous pouvez voir la configuration de votre switch, en tapant la commande suivante :

show run
Publicités

Laisser un commentaire